Los foros del Guille

Si no encuentras respuesta, puedes buscar en el sitio del Guille

Google
 

elGuille.hosting: La oferta recomendada:
.NET 2.0, SQL Server, 1200MB, 10GB transf. por 9.95 Euros al mes

Selecciona el foro y pulsa en mostrar:     Mostrar 
De tu interés (algunos de los avisos publicados)

15/sep/2007
Nueva opción para ver los hilos resueltos: Ver los mensajes resueltos
Por favor acuérdate de marcar los que te respondan correctamente para que esto sea de utilidad. Gracias.

  Foro: .NET.LINQ Cantidad:  Desde:   Hasta:    Aplicar   Responder 
Respuestas a: 51563 - LINQ to Entities
IDAsuntoFechaNick 
51563 LINQ to Entities19/01/10 11:27Samuel Garrido   
Tengo un problema con el siguiente codigo:
using System;
using System.Collections.Generic;
using System.Linq;
using System.Data;
using System.Data.EntityClient;
using System.Data.Common;
using System.Web;
using System.Web.UI;
using System.Web.UI.WebControls;
using ClassLibrary1;

namespace WebApplication1
{
    public partial class _Default : System.Web.UI.Page
    {
        protected void Page_Load(object sender, EventArgs e)
        {
            try
            {
                //Select de LINQ
                var db = new ClassLibrary1.Database1Entities();
                var coches = db.Vehiculos;
                var resultado = from co in coches
                                select new
                                {
                                    co.idVehiculo,
                                    co.matricula,
                                    co.fechaEntrada,
                                    co.fechaSalida,
                                    co.idPersona
                                };

                //Datos de la Select en GridView
                GridView1.DataSource = resultado;
                GridView1.DataBind();
            }
            catch (Exception ex)
            {
                throw ex;
            }

Cuando lo depuro muestra el siguiente error:
La conexión con nombre especificada no se encuentra en la configuración, no es apropiada para ser utilizada con el proveedor de EntityClient, o no es válida.

No se a que se debe porque sigo todos los pasos de su manual "Aprenda C#3.0".

Saludos y Gracias

[Editado: Samuel Garrido, 19/01/2010 11:48:19]
[Samuel Garrido, 19/01/2010 11:48:38]

 
(c) Guillermo 'guille' Som, 2005-2018  - foros.elGuille v1.0.5.3 (23/Mar/2009 14:50 GMT +1)  - (ASP.NET 2.0 v2.0.50727.8762)
 
Usuarios activos: 100 - App. iniciada: 18/07/2018 13:47:17 GMT - La hora GMT del servidor es: 18/07/2018 14:44:18 GMT