Los foros del Guille

elGuille.hosting: Ofertas de alojamiento
posiblemente los mejores precios
¡¡¡ Ahora con el doble de casi todo !!!

Si no encuentras respuesta, puedes buscar en el sitio del Guille

Google
 
Selecciona el foro y pulsa en mostrar:     Mostrar 
De tu interés (algunos de los avisos publicados)

29/mar/2006
Utiliza asuntos descriptivos así será más fácil saber de que trata tu duda y facilitarás la tarea de los que responden a los mensajes.
Gracias.

  Foro: .NET.LINQ Cantidad:  Desde:   Hasta:    Aplicar   Responder 
Respuestas a: 51563 - LINQ to Entities
IDAsuntoFechaNick 
51563 LINQ to Entities19/01/10 11:27Samuel Garrido   
Tengo un problema con el siguiente codigo:
using System;
using System.Collections.Generic;
using System.Linq;
using System.Data;
using System.Data.EntityClient;
using System.Data.Common;
using System.Web;
using System.Web.UI;
using System.Web.UI.WebControls;
using ClassLibrary1;

namespace WebApplication1
{
    public partial class _Default : System.Web.UI.Page
    {
        protected void Page_Load(object sender, EventArgs e)
        {
            try
            {
                //Select de LINQ
                var db = new ClassLibrary1.Database1Entities();
                var coches = db.Vehiculos;
                var resultado = from co in coches
                                select new
                                {
                                    co.idVehiculo,
                                    co.matricula,
                                    co.fechaEntrada,
                                    co.fechaSalida,
                                    co.idPersona
                                };

                //Datos de la Select en GridView
                GridView1.DataSource = resultado;
                GridView1.DataBind();
            }
            catch (Exception ex)
            {
                throw ex;
            }

Cuando lo depuro muestra el siguiente error:
La conexión con nombre especificada no se encuentra en la configuración, no es apropiada para ser utilizada con el proveedor de EntityClient, o no es válida.

No se a que se debe porque sigo todos los pasos de su manual "Aprenda C#3.0".

Saludos y Gracias

[Editado: Samuel Garrido, 19/01/2010 11:48:19]
[Samuel Garrido, 19/01/2010 11:48:38]

 
(c) Guillermo 'guille' Som, 2005-2017  - foros.elGuille v1.0.5.3 (23/Mar/2009 14:50 GMT +1)  - (ASP.NET 2.0 v2.0.50727.8762)
 
Usuarios activos: 77 - App. iniciada: 18/11/2017 18:43:39 GMT - La hora GMT del servidor es: 18/11/2017 19:37:19 GMT