Los foros del Guille

Si no encuentras respuesta, puedes buscar en el sitio del Guille

Google
 

elGuille.hosting: La oferta avanzada:
.NET 2.0, SQL Server, 4000MB, 30GB transf. por 19.95 Eur al mes

Selecciona el foro y pulsa en mostrar:     Mostrar 
De tu interés (algunos de los avisos publicados)

29/mar/2006
Utiliza asuntos descriptivos así será más fácil saber de que trata tu duda y facilitarás la tarea de los que responden a los mensajes.
Gracias.

  Foro: Pocket PC Cantidad:  Desde:   Hasta:    Aplicar   Responder 
Respuestas a: 55453 - Problema para conectarme al SQL
IDAsuntoFechaNick 
55453 Problema para conectarme al SQL23/06/11 13:28edconsi   
Buenos días,
El problema que tengo es que el Servidor se llama nombreServidor\NombreInstancia y esa barra "\" en el medio me esta jugando una mala pasada. Estoy desarrollando en C# para PDA.
Estuve viendo mucha info al respecto, pero ninguna pudo ser la solución. Cuando quiero ejecutar el string de coneccion al servidor que tiene ese tipo de nombre, el "\" hace como un salto y trunca todo lo que sigue.
Se que ese operador en C# se utiliza para comentar texto y que por esta razón me invalida lo que quiero hacer...
La única solución es desinstalar el SQL y volverlo a Instalar de forma que quede con un solo nombre?? no existe otra solución??
Gracias y espero sus comentarios
IDAsuntoFechaNick 
55467 Re: Problema para conectarme al SQL (Resp: 55453)25/06/11 01:30Asterixco   
El problema es que la secuencia \N se transforma en un carácter de salto de línea. Lo más sencillo sería simplemente duplicar la barra: nombreServidor\\NombreInstancia.

Información adicional de MSDN sobre cadenas en C#:
string (Referencia de C#)
Literales de cadena en la especificación de C# para Visual Studio 2003, muy antigua pero aplicable a este caso.

--------------------------------
Ramón Sola
(Para ayudar en lo que se pueda)


Si esta respuesta resuelve tu duda, por favor pulsa en la de este mensaje. Gracias.
IDAsuntoFechaNick 
55494 Re: Problema para conectarme al SQL (Resp: 55453)27/06/11 13:37edconsi   
Gracias por tu respuesta, pero la verdad es que eso ya lo probé y no funcionó...
Puede ser que el SQL sea EXPRESS ? Hay que tener un st5ring de conección especial por esto?
No se por donde buscar la solución.. ya probe todo y nada hace que pueda realizar la conección.

Hoy en día probe con estos string de coneccion:
string Laconec = @"Data Source=SIS-10\SQLEXPRESS;Initial Catalog=Santo;User ID=esteban;Password=kiba";
string Laconec = @"Data Source=SIS-10\SQLEXPRESS; Integrated Security=False; Initial Catalog=Santo; User ID=esteban; Password=kiba;";
string Laconec = "Data Source=SIS-10\\SQLEXPRESS;Initial Catalog=Santo;Integrated Security=SSPI;Trusted_Connection=false;User ID=esteban;Password=kiba";

La verdad es que ya no se por donde mirar....
Saludos
[Editado: edconsi, 27/06/2011 13:43:20]


Si esta respuesta resuelve tu duda, por favor pulsa en la de este mensaje. Gracias.

 
(c) Guillermo 'guille' Som, 2005-2017  - foros.elGuille v1.0.5.3 (23/Mar/2009 14:50 GMT +1)  - (ASP.NET 2.0 v2.0.50727.8762)
 
Usuarios activos: 93 - App. iniciada: 20/11/2017 14:38:06 GMT - La hora GMT del servidor es: 20/11/2017 15:23:47 GMT